Google Gmail Logo

Fixing Gmail Bug On Mac OS X 10.9 Mavericks Mail App

Update: How To Fix Mavericks Mac OS X 10.9.2 Gmail Bug

Update: Mail Update For Mavericks Mail 1.0 Released: Gmail Bug Fixed

Google Gmail LogoSince the launch of Mac OS X 10.9 Mavericks both Google’s Gmail and exchange accounts are not working correctly in the native mail app client in Mavericks. I face this bug, too. Apple is already working on fixing this problem, report 9tomac. In the meantime you can fix the bug for Google’s Gmail IMAP accounts following this work around. Up to now, there is no fix for exchange accounts.

The trick is to deactivate ‘Show in IMAP‘ for ‘All Mail‘, delete every single Gmail account in the native mail app in Mavericks, reactivate it and set up your Gmail accounts again:

  1. Open the native mail app client in Mac OS X 10.9 Mavericks.
  2. Log in your Gmail account in the web browser.
  3. Go to the settings wheel (right corner below your account image) and click on ‘Settings‘.
  4. Click on ‘Labels’, deactivate ‘Show in IMAP‘ for ‘All Mail‘ and go to your inbox (change in settings will be saved).

    Source: miApple.me

    Source: miApple.me

  5. Close the native mail app client in Mac OS X 10.9 Mavericks.
  6. Go to ‘Preferences‘ in Mavericks, choose ‘Internet accounts‘ and delete all Gmail accounts. Important: Be sure that you had got an IMAP account set up. In the other case all your POP3 mail will be deleted.
  7. Go to your Gmail account in the web browser again, go to the settings wheel (right corner below your account image) and click on ‘Settings‘.
  8. Click on ‘Labels’, activateShow in IMAP‘ for ‘All Mail‘ again and go to your inbox (change in settings will be saved).
  9. Open the native mail app client in Mac OS X 10.9 Mavericks. Note: No Gmail accounts should be shown!
  10. Go to ‘Preferences‘ in Mavericks, choose ‘Internet accounts‘ and add all Gmail accounts you deleted before. Last, but not least: You have just to wait some minutes, hours or days depending on the size of your Gmail mailboxes until the Gmail accounts work correctly again. In my cases it takes several hours for my main mail account and some ten minutes for my smaller accounts.

De-activating and re-activating ‘Show in IMAP’ for ‘All Mail’ fixes the bug in native mail client on Mac OS X 10.9 Mavericks. However, there is no fix to solve the same problem for exchange mail accounts. 

Stay tuned! ;-)

About 

Hi there,

my name is Gee Are and I’m the founder and owner of this blog called miApple.me.

miApple.me - Blogger and Online-Journalist. Applemaniac - Keen On Apple Products! Technomaniac - Your Problem Solver For Microsoft And Apple Related Issues!

Grown up with a Commodore C64 and Basic in the 80's. More than twenty years of experience with Windows PCs. Since 2011 keen on Apple and Apple products.

I post about my personal Microsoft and Apple products and problems on miApple.me. I provide solutions to problems people are faced with.

    Find more about me on:
  • facebook
  • flickr
  • googleplus
  • linkedin
  • pinterest
  • skype
  • twitter
  • youtube
20 replies
Newer Comments »
  1. Eddie
    Eddie says:

    It worked for me too. I no longer have an archive folder, however all my previous email that were in my inboxes is now gone :(

    Reply
    • Gee Are Pabst
      Gee Are Pabst says:

      Hi Eddie,

      wait and see! It can take a longer time until the folders are synchronized again. Have a look into your Gmail account in a web browser and go to your inbox there. If the files are still in the inbox, they will be synchronized again with your Mac.

      Cheers,
      Gee Are

      Reply
  2. jim
    jim says:

    A few years back I followed an excellent article by Joe Kissell titled “Achieving Email Bliss with IMAP, Gmail, and Apple Mail” (http://tidbits.com/article/10253). In that article he recommended unchecking the “All Mail” option back then. I’ve had no problems so far with Apple Mail pulling in my Gmail, most likely due to his sage advice.

    Reply
  3. bjai
    bjai says:

    I just updated to Maverick and my gmail inbox is in small print, too small. I went into settings and changed it to large but only my outgoing mail changed, not incoming. Any suggestions?

    Reply
  4. Rae Betsworth
    Rae Betsworth says:

    I need some serious help and teaching to get my gmail back working properly since installing OS Mavericks aaaaargh…………

    Reply
    • Gee Are Pabst
      Gee Are Pabst says:

      Hi Rae,

      just solely repeat step 4 in this work around for ‘All Mail’ and leave ‘Show in IMAP’ deselected! This was the ‘old’ trick before Mavericks and it looks like it is needed again after update to 10.9.1!

      Let us know if this works in your case, too!

      Cheers,
      Gee Are

      Reply

Trackbacks & Pingbacks

  1. […] the launch of Mac OS X 10.9 Mavericks both Google’s Gmail and exchange accounts are not working correctly in the native mail app client in Mavericks. Up to now, I have not faced this bug in Mac OS X 10.10 Yosemite beta 4 because I still have […]

  2. […] in IMAP‘ for ‘All Mail‘ again (in contrast to my recommendation in ‘Fixing Gmail Bug On Mac OS X 10.9 Mavericks Mail App‘ with the reactivating […]

  3. […] Mail 1.0, dated November 8, 2013, did not fix the Gmail bug completely to all users. I posted a fix to manually overcome the Gmail bug. Hopefully, my fix will not be necessary in the future. Beside this, it is not sure that OS X […]

  4. […] moved mails appeared again in the inbox after a few seconds when I went back to the inbox. I posted a fix to overcome the Gmail bug which perfectly works for me. In the meantime, Apple released an update for the mail.app to […]

  5. […] already posted about a fix for that Gmail bug on Mavericks. This fix works for me quite well. However, there is also an exchange mail bug which […]

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Comment